[CVE-2024-26146] Header Parsing leads to Possible Denial of Service Vulnerability